Well This Sucks – Samsung Galaxy Note 10.1 No Keyboard Lockout

I had a nice rant about Trump all typed in (hunt and peck style on the Samsung ‘soft keyboard’) on my Samsung Galaxy Note 10.1 over at Tallblokes. ALMOST ready to send, but wanted to fix a bit of spelling.

As it sometimes does, it popped up some damnable Google Voice thing (that I can’t find any way to turn off forever). Attempting to get it to go away, and get the “soft keyboard” back, the Damnable Google Voice Thing went away, but the keyboard did not return.

Well, I was frustrated by not being able to just fix one misspelled word and hit “post” on my long comment, but thought “Sometimes it comes back after a soft exit / enter”. If you just tap the power button, it darkens the screen and sort of sleeps, but on another tap wakes up. No Joy. But worse…

Now, not only would the “soft keyboard” not pop up, but I was greeted with the “enter password” login panel as I had a password set for return from sleep mode. OK… How do I type in a password without a keyboard? Bluetooth was off to save power, so I could not just fire up my external bluetooth keyboard (after finding it somewhere…)

OK, resigned to losing all of my comment in a complete reboot, I held the power button down and chose “power off”. Then rebooted.

Oh What Fresh Hell Is This!? Still no “soft keyboard” and still demanding a password to log in.

On what planet does a power off / restart not cause a “restart”?…

OK, took out the (encrypted) secondary storage chip. Hoping the change of hardware might tickle something. No joy. Reboot. No joy. Then did the “safe mode” reboot (hold volume down and power on start). No Joy. Then the maintenance mode (power button and volume UP at boot). Several choices.

Erase Cache Sector looked most benign. Did it. Reboot. No Joy.

The other two interesting options are a software upgrade from cache (that isn’t going to work) or a software update from external storage (where I don’t have any update to apply).

At this point, all I have left as an option is “Wipe everything and return to factory settings”.

Now I’m pretty good about moving everything to the external chip from time to time, and I’ve pointed some of the defaults at directories on the chip (so photos go there), but, it doesn’t always stick (I think if you take the chip out it forgets even if you do nothing and put it back) and from time to time I’ve had to move stuff over, again. So some unknown amount of “stuff” is likely on the device. A few photos, some downloads, etc. Not catastrophic, but I’d rather not lose them.

Further, I’m not sure that on a wipe and reset the password, that resetting to the same password will let me back into the encrypted external chip. Again, not a horrid loss. I backed it up about 2? weeks ago. But still…

How On God’s Earth

Can Samsung make a device where the keyboard can just go away, then demand the keyboard to enter the unlock code, and NOT have it reset on powerdown / restart?

Unfortunately, the gizmo has a very long battery life when the screen is not lit, and I’d have to wake it up every minute for a couple of days to drain the battery (in the hopes that a dead battery restart might be different…). Beyond that, I can’t think of much short of “wipe and hope”.

The bottom line, for me, is that this means you can not trust a locked Samsung to every let you unlock it.

That means it is imperative to never use a password to lock it. Which means the device must be left unsafe.

Also, since the auxiliary chip is encrypted with the same “unlock code”, you can’t have an encrypted chip either. No unlock code, no chip encryption… Now I’d lived “unlocked” most of the years I’ve had it, and never had a problem. Only in the last 5 or so months have I gone to tying out the encrypted external chip and unlock code. It seemed to work well, and without slowing things down much.

But this is just a deal killer.

I could accept it very occasionally popping up a “voice entry” or “google search” ( that I think is voice search) panel I’d never asked for. Even the sporadic being thrust into stylus writing entry against my will (the only reasonable exit I found was to tap the power button, it sleeps, tap again, it wakes up and you get the keyboard to enter the password and the stylus entry form has gone away leaving you with keyboard again… There is likely something better, but finding it is a PITA) Those “quirks” were annoying, but not damaging.

This is damaging. It has cost me a few hours already. It will cost me more. At the end of the day I’m pretty sure the only answer will be “wipe and reset”, and that means a few more hours. All up, likely a day or two to get back to snuff (depending on if the chip needs a restore too) and even then some unknown amount of photos and documents downloaded will have just evaporated.

That just isn’t acceptable. Coupled with the loss of trust in ever using a password and encryption on the SD card, the device becomes an insecure toy, not a trusted portable system. I must go back to using it as an unlocked random browser screen and not much more.

The only saving grace, really, is that I never did really like the thing enough to do much more than that with it. So I didn’t have a couple of years of “important stuff” on it to lose. That, and being the paranoid Systems Admin sort, I did back up the data some times. About every month. So it isn’t a total loss.

In Conclusion

I can’t really recommend this kind of device with this mode of failure for anything important. Sure, watch YouTube on it. Browse web pages. But nothing you really would care about losing…

Subscribe to feed

About E.M.Smith

A technical managerial sort interested in things from Stonehenge to computer science. My present "hot buttons' are the mythology of Climate Change and ancient metrology; but things change...
This entry was posted in Tech Bits and tagged , , , , , , . Bookmark the permalink.

22 Responses to Well This Sucks – Samsung Galaxy Note 10.1 No Keyboard Lockout

  1. Larry Ledwick says:

    That sort of stuff just makes me nuts.
    Devices which refuse to shut down and such are at the top of my list of “what bone head designed this” The off button should make it go “off” right frigging now, not after it scratches its head for 20 minutes. It at least should have a control key option (I know not relevant to your issue) that does a full power down force off that just pulls the plug on everything.

    That is the reason I am not fond of much of the new stuff. A couple weeks ago one of our sales folks called in late at night trying to figure out how to shut off the NUMLOCK on his microsoft surface.
    Turns out the physical key board does not have a NUMLOCK, the only way to toggle that function is to futz around to bring up the soft keyboard on screen which has that key functionality. Like your situation if you can’t get the soft keyboard up you can’t change that setting (and who knows how many other functions)

    That is one of the reasons I bought my Dell lap top, it has a good old fashioned physical switch on the edge of the keyboard with shuts off wifi, no messing around with settings or functions all you have to do to kill wifi is slide that switch.

    On the other hand it seems to never really shut off, the power switch only appears to put it in deep hibernation, but does not really power down the os, because it comes back up with the same things active it had when you shut it down. So far I have not had the inclination to figure out how to really turn the damn thing off, but I understand your frustration with that sort of thing. I have had several really neat gizmos which got retired and never used again because of some situation like that, that I could not depend on them, or they wouldn’t let me do something simple and obvious.

  2. j ferguson says:

    E.M.
    These things are intended to be used by idiots. Whatever made you think it was for you?

    I bought a kindle Fire 5th Gen 7 inc for $49. It is my only tablet. I like it, but….

    I thought it would be nice to set-up its network interface to work better on our home system. I got a terminal app running on it, found the usual stuff where i expected, and then realized I couldn’t make myself root. I found advice and software to do what is called rooting – not same usage as heard in OZ, but you get the idea.

    After an unbelievable hassle to get the adb drivers accepted in Windows 10, i was able to get at its OS. Then I discovered that although it would admit to having FireOS 5.1.2, which was rootable by all accounts, what it actually has is FireOS 5.1.2.1 which isn’t. In fact there is no real way to find out what it has because the update to 5.1.2.1 has a later date than the one noted in discussions of this problem.

    I can apparently revert the system to real 5.1.2, root it, then lock if from upgrade/updates. But if the current OS is a later version, then I will brick the thing by trying to bring it down to 5.1.2.

    I guess I’ll wait for someone to figure this out.

    I don’t know if I ever mentioned this here, but I revived an old SPARCstation 10 to run an application I have which won’t run on anything else and which I need. Mostly it was the usual thing until I got to the old 1/4 inch cartridge tapes – the kind with the rubber drive belt. Of the thirty or so tapes i have only two had usable belts, all the rest had stretched to be unusable. Fool that I was, I supposed that I couldn’t possibly be the only one with this problem and searched the web for belts or good cartridges i could get one from, but alas….

    So i moved the good belt from cartridge to cartridge and finally dumped all the tapes onto 5 gig 8mm tapes, which by the way work fine after 23 years in a closet.

    I was also able to revive the old SPARC printer – which uses the computer to rasterize what is to be printed. Also got Ghostprint compiled to run on SunOS 4.1.4 so I can use it as a network printer.

    It looks like there is a choice between spending money or time. Can’t save both.

  3. Ian W says:

    A quick search of the fora shows that you are not alone – others have the same problem and also have found no answer. Time to berate Samsung

  4. j ferguson says:

    Samsung includes DLNA software on their “SMART-TV” which will accept DLNA feeds from a system on your network which can provide them, slides, videos, and MUSIC. But, SAMSUNG does not play albums by track sequence, rather it is alphabetical. This might work ok with songs, but not so good with concerti, symphonies, and so forth.

    This shortcoming was discovered and complained about in detail on Samsung’s user support forum, but to no avail. Even though there have been 3 updates for the firmware on the TV, this is still screwed up. the official response from Samsung was that they had no intention of fixing it.

    My Raspberry Pi 3 is my answer to this problem.

  5. p.g.sharrow says:

    @EMSmith; It would appear that you are dealing with a series of features run-amuck. Locking the security/password feature may well cause a drop dead event cascade. :-(
    Touch screen typing and pointer tracking seems to be fraught with erratic problems. My lady and her son have Samsung devices that they use, THANKS to AT&T, Cellphones and tablets that are often flaky. KILL and start over seems to be the only patch that works…………. for awhile…pg

  6. E.M.Smith says:

    OK, some beers and a long night later…

    I’m going to see if attaching it via the power/dongle cord to a Windoz box might, maybe, cause it to act as a disk drive and show the files. I expect that to not work (or perhaps prompt me for the password at the non-functional interface again).

    After that, I’ll just wipe it and accept the loss of “whatever” weeks of misc papers downloaded and photos that missed the SD chip. Not a lot, but annoying.

    @John Silver:

    I have just such a case / bluetooth keyboard. I use it if I think I’m going to type a lot. It works OK, but is a bit clunky when just laying on the bed… When not in use, I turn of the bluetooth radio to save power and extend battery life. Unfortunately, I can’t turn bluetooth back on until I get past the password lockout…

    @Ian W.:

    Thanks for checking the fora… you have saved me some time. I was too busy last night drowning my sorrows pondering the issue to do that search myself…

    @P.G.:Sharrow:

    And folks wonder why I “waste my time” doing things like making my own computer, and soon to be, my own tablet… Were this a home brew, I’d just pop open the (slightly fatter) case, do a hard power reset or, at worst, move the internal SD card to another box and read it, then reset.

    I suspect I’ll be making my own tablet / phone soon enough. The old “flip phone” is having the chrome bits around the keys debond and it is making ‘edges’ that are uncomfortable… Battery down to about a day now too.

    Features run amuck? Basically yes. The result of “interface overloading”. There is a “pinch mode” that I think is the issue. I never intentionally use it. It is supposed to “change your keyboard type” between writing/stylus, soft keyboard, and some kind of voice entry. I’d like to just lock it out, but engineers in love with themselves never want to provide a “Do Not Do Your New Brainfart Feature!” key… What I think happens is that my large non-Japanese Neanderthal farmers fingers overlap the edge of the pseudo keyboard just enough sometimes that IFF I am typing and a finger drags just a little toward the next key, that is taken as a ‘pinch’ and POOOFFF! I have an alien “keyboard” (that sometimes is just voice input). Yet then, no amount of “pinching” gets me back…

    @J. Ferguson:

    That’s the direction I’m headed. Pi and similar all the way. (Likely to branch out into a cubietruck for the SATA interface for the file server…).

    But I bought the tablet some years ago… Why did I think it might be “for me”?

    I was “on the road” at the time and the HP Laptop was suffering slow degradation failures. Battery not taking charge, key caps worn smooth so touch type only, etc. Then the fan started to sporadically not cool (now never cools). Tablets were fairly new (to me at least) and I thought maybe one could serve as a browser and posting station at Starbucks.

    Further, I was at Disney on contract. I tend to use a nice folio / paper pad for notes. Many other folks were using laptops and looking at me like “how old school” (not helped by graying hair…) Partly I bought it for “contract theatre”. I’d occasionally use the “note” feature to draw what was on the board, or just photo it, and sometimes took notes with the stylus (even though slower and much more error prone / crude than a good pen on paper). I fairly quickly figured out it was better to use paper if I was serious about the notes, but often engaged the Theatre Function ;-)

    It was worth it just for that. Oh, and for the videos I’d watch on it in the hotel room ;-)

    That was about 3? years ago. Before the Raspberry Pi Model 2 back when the only avilable Pi models were not sufficient for daily drivers or anything video…

    Then about a year? back the HP Laptop finally had the fan entirely die. The only “portable” I had for things like watching youtube in bed or reading web sites at Starbucks was the tablet. It got more consistent use… but just as “display point” really. With occasional downloads and sporadic picture taking if nothing else was available.

    It has been “worth it” to me, until now. During all that time I’d not tried the “security password” feature out of just this kind of issue caution. Only recently did I decide to see if you could use this thing to hold a 32 or 64 GB SD chip and keep it encrypted and secure. The idea being an easy browsing and storage platform for air travel that was not subject to “deep inspection” if taken to the back room… (Figuring a Pi, heap of cables, battery pack, and such just might be harder to get though the carry on TSA point…) Well, OK, now I have my answer.

    BTW, it claims to be doing a full power down, not just a sleep, and gives me the ‘fresh boot up’ panel with the Samsung logo and all when I tell it to “power down” (via a long hold of the power button and a ‘tap to choose’ panel that does work). It seems to cache keyboard type in use “somewhere” between boots. I’m sure somewhere someone thought this a nice convenience feature for some brain dead reason and never thought about the password entry problem (or the failure to use default keyboard is a sporadic bug he never tickled…)

    That, to me, makes it even more nutty. Either it is lying to me, or it DOES power off, restart, but is still saving a bad state somewhere…

  7. j ferguson says:

    E.M
    There is something very attractive about a Pi based tablet. And everything on an easily remove chip. I hadn’t thought about it, but getting the thickness down might not be all that hard, particularly if it was going to be a dedicated processor. Then again, it may be possible to build up something that just does what you want from an Edison,

  8. E.M.Smith says:

    @J. Ferguson:

    Many have been made. I like the look of this one a lot:

    http://makezine.com/2014/01/07/how-I-built-a-raspberry-pi-tablet/

    The first found in a duckduckgo search:

    How I Built a Raspberry Pi Tablet | Make:
    Make this impressive Raspberry Pi all-in-one PiPad which is usable, portable, and Linux based.
    [Search domain makezine.com] makezine.com/2014/01/07/how-I-built-a-raspberry-pi-tab...
    
    raspberry pi in "Computers, Tablets, and Networking" | eBay
    Find raspberry pi raspberry pi model b from a vast selection of "Computers, Tablets, and Networking". Get great deals on eBay!
    [Search domain rover.ebay.com] rover.ebay.com/rover/1/711-53200-19255-0/1?icep_ff3=9&pu...
    
    Raspberry Pi Tablet - Instructables
    Intro: Raspberry Pi Tablet. This Christmas, my brother gave me a Raspberry Pi 2 and the official 7 inch touchscreen. Wanting to make use of this great gift, I decided ...
    [Search domain www.instructables.com] instructables.com/id/Raspberry-Pi-Tablet/
    
    Build Your Own Raspberry Pi-Powered Tablet - Lifehacker
    Tablets are typically expensive and don't exactly offer up much of chance for customization. If you don't mind making your own tablet, DIYer Michael Castor shows off ...
    [Search domain lifehacker.com] lifehacker.com/build-your-own-raspberry-pi-powered-table...
    
    Official Raspberry Pi touchscreen will let you build your own ...
    The Raspberry Pi's DSI connector has yet to be called into active duty by the Foundation, but that's about to change. There's an official Raspberry Pi ...
    [Search domain www.geek.com] geek.com/tablets/official-raspberry-pi-touchscreen...
    
    PiPad Raspberry Pi tablet: a $350 DIY project | BGR
    The PiPad is the name Michael Castor gave to the Raspberry Pi wood and carbon fiber tablet he built after gathering all the necessary parts. "It seems ...
    [Search domain bgr.com] bgr.com/2014/01/15/pipad-raspberry-pi-tablet/
    

    I’ll make one “someday” just because anything you buy is going to be full of lock-ins, data leakage, adware, and other garbage..

    It doesn’t look all that hard. Mostly glue on a battery and touch screen and put it in a container. Oh, and stick in a wifi dongle or use a Pi 3.

  9. E, M.Smith says:

    WELL, THIS CONFIRMS IT.
    Even setting the same password, the Magic Number isn’t right and the encrypted SD card does not uncrypt. The warning at the turn on encryption panel says as much.
    Essentially, lose the keyboard, you are 100% screwed.

    So I’m back at a couple of weeks ago, even for the SD card, even though I have the password…
    I can think of ways to use that… but thrust on you by surprise could be catastrophic.

    OH WELL…
    ANY Samsung device must be considered risky at best and subject to 100% data loss with no hope of recovery at all times, by surprise, and with zero notice and zero mistaken action.
    Not good for Samsung…

  10. Larry Ledwick says:

    You would think that they could solve that problem somehow, I presume they already know what action caused the key board to become unavailable?

    Regardless there must be a setting some place that activates the key board like (keyboard = yes). If all else failed they could put a time out on the disabled keyboard (ie you could only disable it for 24 hours or something like that then it would reactivate with no key board input. Or perhaps some utility on a usb that when plugged into the usb port and the handshake occurs to connect the external device it interrogates the keyboard status and corrects it if disabled. Bad news is that might be a vector for malware.

    Definitely a bad deal as the news gets out. I also have a small samsung tablet which right now I don’t use since I killed my digital service to it to save money, but I would definitely like to know what is going on, otherwise it is just a very expensive paper weight.

  11. Larry Ledwick says:

    If I missed mention of this above, sorry, but can you plug a physical usb keyboard into the usb port you use for charging and have the tablet recognize it without completing the login process?

  12. E.M.Smith says:

    @Larry:

    Interesting
    idea… I could likely have cobbled togeter a connection via a hub
    using kit in hand, had I thought of it.

    To late now as I’ve already done the reset. Not a big loss, though.
    Maybe a couple of photos of BSD building xorg and a few downloaded pdfs
    per climate and LFS books. All public.

    FWIW, I’m typing this in the IceCat browser on the tablet. It is the
    privacy enhanced Firefox derivative with modified Javascript to fix
    security issues. Seems a bit slower to open pages, but probably worth
    it.

  13. Larry Ledwick says:

    If nothing else it would be useful to try it now after the reset and see if you need a special driver or something to make it work as a future backup to the soft keyboard.

  14. E.M.Smith says:

    Odd you should say that….

    We seem to think alike, I just finished the test and came to post the result and saw your suggestion :-)

    One must use the “special” Samsung to USB cable (that only lets you charge from the “special” Samsung power brick…) to get a USB spigot. Plugged into the hub, it saw it (tablet put the red X overlay on the battery symbol) but no joy on keyboard or mouse doing anything. The “settings” panel gave me a choice of turning off Google Voice (that I thought I had already done a few times…) and the default Samsung soft keyboard that can never be shutoff…. but was the one that went away ….

  15. E.M.Smith says:

    Interesting bit of data leakage on the “encrypted” SD card…

    Mounted either to the ‘reset’ tablet or to a Raspberri Pi (so also any other linux box and likely any Windows box too…) the SD card shows the names and formats of all the directories and files…

    pi@raspberrypi:/media/pi/9016-4EF8 $ ls -l
    total 384
    drwx------  5 pi pi 32768 Feb  2 02:46 DCIM
    drwx------  8 pi pi 32768 Jun  7 17:44 Download
    drwx------  2 pi pi 32768 Jun 17  2015 LOST.DIR
    [...]
    drwx------  2 pi pi 32768 Nov  8  2013 Music
    [...]
    drwx------  2 pi pi 32768 Apr 29 11:43 Pictures
    drwx------  3 pi pi 32768 Apr 29 11:45 S note
    drwx------  2 pi pi 32768 Apr 29 11:43 S Note Export
    
    pi@raspberrypi:/media/pi/9016-4EF8 $ cd download
    pi@raspberrypi:/media/pi/9016-4EF8/download $ ls -l
    total 2297088
    -rw-r--r-- 1 pi pi    102400 Apr 11  2015 0821ctt-mullite-converters_lo-res.png
    [...]
    -rw-r--r-- 1 pi pi   7217152 Dec 13 22:55 12. The Grasses.pdf
    -rw-r--r-- 1 pi pi    364544 Apr 11  2015 1401.7738.pdf
    -rw-r--r-- 1 pi pi     90112 Apr 11  2015 1410528351000-snow.png
    -rw-r--r-- 1 pi pi     28672 Apr 11  2015 1410533446000-South-Dakota-Summer-S_Klin.jpg
    -rw-r--r-- 1 pi pi    118784 Apr 11  2015 150227-slurpee-waves-high-res.nbcnews-ux-1360-900.jpg
    [...]
    -rw-r--r-- 1 pi pi     45056 Apr 11  2015 2012-08-diesel-exhaust-platinum.pdf
    [...]
    -rw-r--r-- 1 pi pi    151552 Dec 13 22:52 36cdpw-smason.pdf
    -rw-r--r-- 1 pi pi    610304 May 10 03:46 44_md_ao_45_aminov_liana_c_907-913.pdf
    -rw-r--r-- 1 pi pi   1327104 Nov 28  2013 5740-pdf.pdf
    ...
    

    There is one heck of a lot of information about someone in all that metadata. What you accessed, when you accessed it, etc. etc.

    Anyone thinking that Samsung provides actual privacy is just being fooled. It, at most, encrypts the contents of each file individually. But does nothing to prevent a Bad Guy from knowing a LOT about you and what you do, and lets them rapidly focus in on the one or two files worth spending computes to crack.

    This is just horrid pseudo privacy…

    (For me, now, it is a ‘good thing’ in that I can compare the contents of the SD chip with my backup and know exactly what I need to download again… but in any non-recovery context, it is just a lousy way to “encrypt” things… )

  16. Larry Ledwick says:

    Well that is sort of a dog and pony show way to do encryption!
    Like you say if someone uses descriptive file names it gives away a whole lot of info.
    The file named “all_my_passwords” and the file named “my_investments” might get someone’s interest.

  17. E.M.Smith says:

    Or even a download of Roxxxy.jpg or defeating_capitalism.pdf … or bypassing-great-firewall-china.txt could cause trouble in some places…

  18. Larry Ledwick says:

    As you have mentioned in the past it does make you wonder.
    a. The security is intentionally crippled
    b. They threw encryption in there only as a sales gimmick but really don’t give a crap if it is secure.
    c. Their developers are really not that good or simply don’t understand how complex security is.
    d. They were on deadline and somebody said “skip it no one will know”
    e. Their test and evaluation, and requirements folks are not too good and build really weak test cases, or have slip shod requirements.
    f. They were just checking a box on a check list and did little testing or red team attacks on the system

    Some of all of the above.

  19. Ian W says:

    Larry Ledwick says:
    8 June 2016 at 5:55 am
    From experience it is e and f on your list that start the rot. But that leads to c not being discovered and can then iterate leading to a continual drop in quality. Security is not something that most users can or will test either.. So everyone can be fat dumb and happy, including the APTs

  20. EG Caldwell says:

    Six months ago, I purchased a Samsung Galaxy V at what appeared to be a good price.
    It has turned into an ISP –Incredibly Stupid Purchase.

    I thought I would enter a password to protect my network access from others. For four months, it accepted my password. Then it claimed my password was invalid. I managed to get in by resetting the device (remove and replace battery) and my password was valid. For that use. While I was in, I explored all the settings to see if the password could be refreshed. No. Could it be changed? No. Could it be deleted? No. Could it be turned off? No.

    It is most likely that I have overlooked something, but I no longer care. I am going to exact a lot of satisfaction from destroying it. It’s now awaiting its final adjustment from my big hammer. It’s the second Samsung handset I have had. It’s going to be the last. (Did you read this Samsung?)
    The best of luck with your own investigations, EM, you have far more patience than I could afford to have at the time it pulled its stunt on me (Partner arriving home on a flight and me needing to access her text to discover arrival time for pickup etc. Urgent and Very Important Stuff.).

Anything to say?

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s